Download Empeld Launcher


Create Account

Once you’ve downloaded the launcher, head over to the Auth Portal to create an account!


Prerequisites

Windows

Most modern versions of Windows come with, or already have, the .NET Framework, so you should be all set.

If not, you can download the runtime from Microsoft’s website.

Mac

You will need to install the latest Mono Runtime Environment (MRE). Once you do that, you will be able to run the launcher normally.

If you have any problems, feel free to contact us.

Linux

You will need a modern version of Mono from apt or yum

$ sudo apt-get install mono-complete

If you think you might already have it installed, you can check by running:

$ mono --version

Once you do this, you should be able to double-click on the launcher to run it. If that still doesn’t work, try running it in a terminal by typing the following:

$ cd /path/to/launchder
$ mono empeld.exe